A brief one this week - but seems like something that it would be good to share: Did you know there can be hard content limits in Content Hub that can stop you working once they're exceeded?
url copied!
A customer has been working on some import code, to get PCM products and CMP content into Content Hub for project. The work is dealing with thousands of items overall.
When the first "full import" was run against their non-prod instance, it worked for a while and then failed with the following error:
Entity limit (10500) is reached and cannot be saved.
This affected both API calls to create entities, and trying to use the UI to set up new content by hand.
This was a completely unexpected error. While we were aware that Content Hub has license provisions for disk storage and item counts, we were confident we were within the client's licensed scale. Plus we'd been told the limits were soft ones, which affected future scaling charges rather than hard ones which would prevent work immediately they were breached.
So why the error?
url copied!
Well, having raised this as a support ticket, we were told that the it was down to a "misconfiguration". Support fixed whatever that was, and our code went back to working as soon as they did. But we got no indication of how/why it ended up in this state.
So, one to watch out for:
If you're doing large imports against Content Hub (in non-prod certainly, but maybe in production too), this is an error you might see. If you're confident you're within your license terms then speak to support, and they can help you get this resolved.
↑ Back to top